Accelerometer data streams but no EEG

tegestologisttegestologist United States
Hi.  I bought a used Mark IV from Ebay.  The seller claims the system was working when they shipped it.  It came with Cyton, daisy chain (16 chans) and the wifi shield.  Everything powers up (blue lights, etc) and I can connect to the GUI via Cyton with 8-channels.  The accelerometer data streams and responds to physically moving the board.  However, the EEG channels show no data either when the electrodes are on my head or when I touch the inputs per the install instructions.  Also, when I try plugging in the daisy chain board, GUI says "Daisy is not attached to Ctyon board..."  

I have tried on two PCs and one Mac computer.  Same issues.  Did I buy a lemon?

Thanks!

Comments

  • wjcroftwjcroft Mount Shasta, CA
    Jay, hi.

    Wow, I took a peek at your email address. I've listened to your presentations on Transcranial Ultrasound at the Transformative Technology Conferences. And know your partner Sanjay as well. Way impressed with all your work. Welcome.

    Regarding your Ultracortex and Cyton. Have you tried the simplest possible configuration first: no Wifi Shield, just the Cyton 8 channel board, no Daisy. Connecting via the OpenBCI dongle. Does that work ok with the GUI? I'm unclear from your description if your Cyton 8 channel test was with the serial port dongle.

    Do you have an approximate date when the original owner received the Cyton? It might have out of date firmware. When you first bring up the GUI, it should show you the firmware level at the bottom of the screen after you select the serial port in the System Control Panel menu and press the  Start System button.

    It's possible that there is something odd with the Reference (SRB2) lead connection that goes to one of the ear clips. The other clip goes to Bias.

    The steps in the tutorial, for first bringing up the Cyton, have NOTHING connected to the input pins initially. Is that the configuration you were using? Set your time series display on Auto scale, in case there might be some scaling problem.

    Regards,

    William

  • tegestologisttegestologist United States
    Thank you for the kind words, William.  I feel lucky to do my research!  I'm happy to chat anytime about ultrasound neuromodulation or technoboosts for mindfulness. 

    And thanks for your input. I'm a big fan of the Open BCI project and was happy to acquire a system for the lab.  We are going to create a closed-loop brain stimulation system with the Ultracortex. Such interesting times!  So, as you can imagine, I'm a bit bummed it's not working.  

    Sorry for the lack of clarity.  Yes, I tried it with only the Cyton 8 channel and the serial port dongle with nothing connected to the input pins.  Same issue -- I see the accelerometer data streaming but nothing on the EEG channels. I tried fidgeting with the scales but that did not help. 

    The Cyton  firmware is 3.1.0.

    Thanks, again.


  • wjcroftwjcroft Mount Shasta, CA
    Jay, thanks.

    Your firmware version sounds close to current (3.1.2),


    The 3.1.0 dates your board as likely from late 2017 or early 2018. Did the previous owner check it out before shipping? The 3.1.0 'should' work ok with the GUI, using dongle. Two possibilities come to mind for no EEG:

    (1) in rare cases the flash memory of the PIC32 processor might have glitched. So reflashing would be the first thing to try. Also for Wifi Shield operation you'll want 3.1.2 and also the latest shield firmware. Flashing / upgrade instructions here,


    (2) Although the input pins of the board have EMI / ESD protection (against static discharge or ElectroMagnetic Interference), the rest of the board surface, traces, etc, is NOT static discharge protected. If somehow the board took a static hit, it could have knocked out the A/D chip, the ADS1299. However if that was the case it would board would likely be completely dead and not managing to stream accelerometer. So my hunch is that it may be the flash is somehow wonky.

    So give the 3.1.2 flashing a try. You should be able to confirm that with the GUI after you're reflashed.

    Regards,

    William

  • tegestologisttegestologist United States
    Thank you for the help!  I'll try flashing the memory and will let you know how it goes.  Fingers crossed. 
  • tegestologisttegestologist United States
    Hi William.  I flashed the Cyton board to 3.1.2.  When connecting to the dongle, I still get the same issue - accelerometer data streams just fine but there is no EEG stream.  I also tried updating the wifi shield and connecting that way (both via wifi station and wifi direct).  I can connect in the GUI, get an IP address, and I see the wifi software version number.  However, when I flip the little switch on the wifi shield to power the Cyton board, it still says "none" under "OpenBCI Board."  Of course, I also tried powering on the wifi shield and cyton before connecting to the GUI but I still see the same issue.  Do you think the Cyton board is faulty? 

    The previous owner claims they connected to the gui via the wifi shield and that they saw EEG data.

    Thanks, again!
  • wjcroftwjcroft Mount Shasta, CA
    Jay, well sorry to hear that.

    At this point I suggest you email to contact at openbci.com (the lab in Brooklyn) and ask if they have any other suggestions or options. Mentioning @openbci. I'm not sure there are any repair options for broken boards.

    Here is one other thing you could try with the Cyton board alone + dongle. Connect a terminal emulator to the serial port device name that the dongle is using. Arduino IDE has such an emulator (called Serial Monitor), there are many others; probably more available for PC than Mac. Set the baud rate to 115200. Then power the Cyton up. It will print the firmware level. When you type a single question mark, (or question mark return on the Arduino serial monitor), the Cyton should respond with a register dump of the ADS and Accel. registers. That might give further clues. You could post that result on this thread.

    But given what we know, it sounds like some board component is failing. I assume your battery is in good shape, otherwise the accel would not stream. Are you using a lithium cell or the AA pack? A voltmeter check between Vdd pin and ground (header J3), should show 3.3 volts.

    Regards,

    William

  • wjcroftwjcroft Mount Shasta, CA
    You mentioned initially that the Cyton plus dongle was not recognizing your Daisy. Mention that also on your email to contact. Definitely odd.
  • wjcroftwjcroft Mount Shasta, CA
    Here's one more suggestion. In addition to checking the Vdd, check the plus and minus 'analog' voltages. The Vdd is the main 3.3v logic regulated supply. It must be working for the PIC32 and RFduino to be operational. On the other hand if one of the 'analog' voltage regulator components failed, that very well might explain why all your A/D conversion results are zero.

    Measure these on the header pins that are near the electrode pins (on either end of the row.) AGND is the ground, AVDD to AGND should be +2.5v. And AVSS to AGND should be -2.5v. If one or the other or both of these are not right, that would explain why the logic of the ADS1299 is working, but the A/D conversion is failing. Might also explain the failures of the Daisy.

    Mentioning @openbci.
  • wjcroftwjcroft Mount Shasta, CA
    The good news is that if this 'analog' voltage regulation is failing, those surface mount component(s) would be easy for a tech to replace. You might even be able to do it yourself with a high quality soldering station. I'm sure the lab there in your area has such equipment and techs. See the circuit schematics and board images here,


    Crossing my fingers that this is fixable on your end.
  • retiututretiutut Louisiana, USA
    I would even contact eBay or return the used product and get your money back. Buying straight from OpenBCI ensures support claims will be handled. I don't think it's right to buy a used and defective product.
  • tegestologisttegestologist United States
    edited June 20
    Thank you for the helpful information William.  I'll try those things when I get back to the lab.

    @retiutut.  Indeed, we plan to send it back if it does not work.  Once our lab gets more funding, which should be soon, we'll be able to buy a new unit direct from OpenBCI. 
  • retiututretiutut Louisiana, USA
    edited June 20
    Full Disclosure: If you had purchased the board from OpenBCI, it would likely get replaced. This is a better scenario than trying to repair such a compact board. Also, flashing the firmware should have fixed the problem.

    I just don't feel that it's right for someone else to "get their money back" from a purchase by selling a defective product to someone else. If the original owner realized it wasn't working, they could have submitted a ticket and gotten the board replaced!!!!!

    Please, just save some money and buy legitimate OpenBCI hardware from OpenBCI to avoid all of this headache. I strongly recommend returning the product via eBay to get your money back.

    Orignal Post: "Did I buy a lemon?"

    Answer: Probably yes.
  • wjcroftwjcroft Mount Shasta, CA
    Richard, other previous Cyton board owners have had the voltage regulator or polarity protection diode chips flake out on Cyton's they've had in their possession for some time. And have successfully replaced the components, with tips from the forum here. (This assumes such customers are Makers / techs to begin with. Jay is a consummate PhD engineer.) Do a search on the forum and you'll find several cases. It's worth checking the AVDD AVSS, because that would explain the symptoms that Jay is seeing.

  • retiututretiutut Louisiana, USA
    edited June 20
    @wjcroft Thanks for sharing that.

    @tegestologist I would still take all of William's advice in regards to a fix! He is one of the people who would know if this is fixable.

    My concern would be attempting a fix and ruining the board entirely. If you have the skills to attempt what William has suggested, I believe this is the cheapest option for your scenario!!!
  • wjcroftwjcroft Mount Shasta, CA
    To do surface mount repairs on boards like this requires advanced soldering skills. But past Cyton's have been repaired on regulator failure. Fortunately the voltage regulator / inverter chips are among the larger ones on the board.

    Also fortunately, this is a rare occurrence. Only a few have been reported here on the forum. 
  • tegestologisttegestologist United States
    Understood.  Before graduate school, I worked at a company that fixed EEG systems.  I have more soldering experience than I ever wanted.  
  • retiututretiutut Louisiana, USA
    edited June 20
    @tegestologist Very nice! I hope this all works out so you can start research! If the fix is successful, please let us know!
  • tegestologisttegestologist United States
    @retuitut Will do.  Thank you for your input and concern, too!
  • tegestologisttegestologist United States
    @wjcroft here is the serial monitor dump mentioned above. Looking into the voltage readings now. 

    OpenBCI V3 8-16 channel
    On Board ADS1299 Device ID: 0x00
    LIS3DH Device ID: 0x33
    Firmware: v3.1.2
    $$$
    Board ADS Registers
    ADS_ID, 00, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CONFIG1, 01, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CONFIG2, 02, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CONFIG3, 03, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF, 04, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH1SET, 05, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH2SET, 06, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH3SET, 07, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH4SET, 08, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH5SET, 09, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH6SET, 0A, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH7SET, 0B, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CH8SET, 0C, 00, 0, 0, 0, 0, 0, 0, 0, 0
    BIAS_SENSP, 0D, 00, 0, 0, 0, 0, 0, 0, 0, 0
    BIAS_SENSN, 0E, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_SENSP, 0F, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_SENSN, 10, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_FLIP, 11, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_STATP, 12, 00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_STATN, 13, 00, 0, 0, 0, 0, 0, 0, 0, 0
    GPIO, 14, 00, 0, 0, 0, 0, 0, 0, 0, 0
    MISC1, 15, 00, 0, 0, 0, 0, 0, 0, 0, 0
    MISC2, 16, 00, 0, 0, 0, 0, 0, 0, 0, 0
    CONFIG4, 17, 00, 0, 0, 0, 0, 0, 0, 0, 0

    LIS3DH Registers
    0x07 00
    0x08 00
    0x09 00
    0x0A 00
    0x0B 00
    0x0C 00
    0x0D 00
    0x0E 00
    0x0F 33

    0x1F 00
    0x20 08
    0x21 00
    0x22 00
    0x23 18
    0x24 00
    0x25 00
    0x26 00
    0x27 00
    0x28 00
    0x29 00
    0x2A 00
    0x2B 00
    0x2C 00
    0x2D 00
    0x2E 00
    0x2F 20
    0x30 00
    0x31 00
    0x32 00
    0x33 00

    0x38 00
    0x39 00
    0x3A 00
    0x3B 00
    0x3C 00
    0x3D 00
    $$$
  • tegestologisttegestologist United States
    @wjcroft Found the following voltages:

    J3 to AVDD : 2.52 v (should be 3.3)
    AVDD to AGND: -2.52 v (should be + 2.5)
    AGND to AVSS: -2.52 v


  • wjcroftwjcroft Mount Shasta, CA
    Jay, thanks.

    Actually on J3 you want to measure between GND (voltmeter black) and Vdd (voltmeter red), both pins on header J3. (It looks like you measured between J3 GND and AVDD?) The J3 Vdd should give 3.3. Check it again.

    Your Analog voltages look ok, because you measured the first one upside down. From AGND (voltmeter black) to AVDD (voltmeter red) would read +2.5. Correct?

    Unfortunately the firmware is not finding the ADS chip Device ID. It's getting ID 0 instead of the correct ID.  Below is a typical dump from an older (V2) Cyton + Daisy. (Without showing the Daisy registers, which are the same as the mainboard.) Your Accelerometer regs look fine.

    OpenBCI V3 8-16 channel
    On Board ADS1299 Device ID: 0x3E
    On Daisy ADS1299 Device ID: 0x3E
    LIS3DH Device ID: 0x33
    Firmware: v2.0.1
    $$$
    Board ADS Registers
    ADS_ID, 0x00, 0x3E, 0, 0, 1, 1, 1, 1, 1, 0
    CONFIG1, 0x01, 0xB6, 1, 0, 1, 1, 0, 1, 1, 0
    CONFIG2, 0x02, 0xC0, 1, 1, 0, 0, 0, 0, 0, 0
    CONFIG3, 0x03, 0xEC, 1, 1, 1, 0, 1, 1, 0, 0
    LOFF, 0x04, 0x02, 0, 0, 0, 0, 0, 0, 1, 0
    CH1SET, 0x05, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH2SET, 0x06, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH3SET, 0x07, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH4SET, 0x08, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH5SET, 0x09, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH6SET, 0x0A, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH7SET, 0x0B, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    CH8SET, 0x0C, 0x68, 0, 1, 1, 0, 1, 0, 0, 0
    BIAS_SENSP, 0x0D, 0xFF, 1, 1, 1, 1, 1, 1, 1, 1
    BIAS_SENSN, 0x0E, 0xFF, 1, 1, 1, 1, 1, 1, 1, 1
    LOFF_SENSP, 0x0F, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_SENSN, 0x10, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_FLIP, 0x11, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_STATP, 0x12, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    LOFF_STATN, 0x13, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    GPIO, 0x14, 0x0F, 0, 0, 0, 0, 1, 1, 1, 1
    MISC1, 0x15, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    MISC2, 0x16, 0x00, 0, 0, 0, 0, 0, 0, 0, 0
    CONFIG4, 0x17, 0x00, 0, 0, 0, 0, 0, 0, 0, 0

    I'll take a look at the firmware briefly and see what might result in a bad ID of zero.

    William
  • wjcroftwjcroft Mount Shasta, CA
    edited June 25
    What is the power supply for the board? AA pack or Lithium cell? Measured voltage of that supply? I assume you've tried swapping out batteries to eliminate the possibility you have a low or bad cell.

    If Vdd is actually marginal (after you measure between GND and Vdd on J3), and not 3.3v as required, then the ADS chip might not be getting enough voltage to function correctly. Since the mainboard PIC32, RFduino and LIS3DH seem to be doing ok -- seems odd that only one chip would be affected. So if this is a 3.3v regulator issue, it's a weird one. Might just be that the ADS chip has gone south. 
  • tegestologisttegestologist United States
    Hi.  One of the research assistants in my lab was doing that testing and posting here today.  I just checked with him, and he said he used both the AA back and Lithium cell batteries for the testing.  He got the same answer with both types of batteries.   Yes, he tried new AA batteries, too (and checked them on the volt meter). 

    Well, this may end up going in the bin of "unsolved mysteries!"

    The seller said he'd give my money back. I guess I'll return it and save up my pennies for a new model direct from OpenBCI.  

    Thank you much for your kind assistance. 
  • wjcroftwjcroft Mount Shasta, CA
    Jay, could the tech please do a correct voltage reading between GND and Vdd (both pins) on the same J3? Just want to double check your 3.3v regulator. As I mentioned previously, the tech appears to have measured Vdd wrong (measuring AVDD instead, according you description.)

    Unless this is a 3.3v issue, it looks like your ADS chip has just stopped responding to polls from the PIC32.

    William

  • tegestologisttegestologist United States
    @wjcroft ;  I measured GND and VDD on the same J3 and read 3.33v.  So it sounds like the ADS chip is faulty. 
  • wjcroftwjcroft Mount Shasta, CA
    Jay, yes, sorry to say. Have not really seen this failure mode before. TI makes very solid chips. Clearly the seller stated that the board was working at one point.

    One last check you could make with a small magnifying lens / glass. Look at all the ADS1299 pins and see if they all look clean and no unusual flakes or particles got lodged somehow between pins. If by some bizarre chance a metal particle got lodged there, it could short things out. The resistors and caps in the vicinity of the ADS are also possible locations; as they are buffering the ADS to the board logic.

    Well, fortunately the eBay return policy saves the day. Feel bad for the previous owner. I wish there was some way to do board level repair. At this point you don't know if the actual ADS chip has failed, or something in the interconnect.

    Regards,
  • wjcroftwjcroft Mount Shasta, CA
    Just watched Jay's talk given at the recent (May 2019) Awakened Futures conference, sponsored by Consciousness Hacking community,



    "Dr. Jay Sanguinetti - Ultrasonic Neuromodulation and Higher States | Awakened Futures Summit 2019"

    And Jay's SEMA lab, at University of Arizona.


Sign In or Register to comment.